2 SELECTING AND ALIGNING

Lesson overview

In this lesson, you'll learn how to do the following:

Differentiate between the various selection tools.
Group and ungroup items.

Work in isolation mode.

‘Worlk with smart guides.

Clone items with the Selection tool.

Lock and hide items for organizational purposes.
Save selections for future use.

Use tools and commands to align basic shapes to each other..

This lesson takes approximately an hour to complete. If needed, remove
the previous lesson folder from your hard disk and copy the Lesson02
folder onto it.

In this lesson, you learn how to locate and select
objects using the selection tools, as well as how to
protect other objects by hiding and locking them.
You also learn how to align objects to each other and
the artboard.




Getting started

When changing colors or size, and adding effects or attributes, you must first select
the object to which you are applying the changes. In this lesson you will learn the
fundamentals of using the selection tools. More advanced selection techniques
using layers are discussed in Lesson 8, “Working with Layers.”

1 To ensure that the tools and panels function as described in this lesson, delete
or deactivate (by renaming) the Adobe llustrator CS4 preferences file. See
“Restoring default preferences” on page 3.

2 Start Adobe Illustrator CS4.

Note: If you have not already copied the resource files for this lesson onto your hard disk from
the Lesson02 folder on the Adobe lllustrator C$4 Classroom in a Book CD, do so now. See "Copying
the Classroom in a Book files” on page 2.

3 Choose File > Open, and open the L2start_01.ai file in the Lesson02 folder,
located in the Lessons folder on your hard disk. Choose View >
Fit Artboard In Window.

Using the Selection tool
The Selection tool in the Tools panel lets you select entire objects.

1 Select the Selection tool (R) in the Tools panel. Position the pointer over the
different shapes without clicking. The icon that appears as you pass over objects
(&) indicates that there is an object that can be selected under the pointer.
When you hover over an object, it is outlined in blue.

2 Hover the pointer over the edge of one of the black airplanes. A word such as
path or anchor may appear because smart guides are selected by default. Smart
guides are snap-to guides that help you align, edit, and transform objects or
artboards. Smart guides are discussed in more detail in Chapter 3, “Creating and
Editing Shapes.”

3 Click the black airplane in the upper left corner. A bounding box with eight
handles appears.

The bounding box is used for transformations such as resizing and rotating. It
also indicates that this item is selected and readv to be modified. The color of the

bounding box indicates which layer the object is on. Layers are discussed more
in Lesson 8, “Working with layers.”

4 Using the Selection tool, click the airplane on the right and notice that the left
airplane is now deselected and only the second airplane is selected.

5 Add the left airplane to the selection by holding down the Shift key and clicking
the airplane on the left. Both airplanes are now selected.
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Add other items to a selection by holding down the Shift key.

6 Reposition the airplanes anywhere in the document by clicking in the center of
either selected airplane and dragging. Because both airplanes are selected, they
travel together.

As you drag, notice the green lines that appear. These are called alignment
guides and are visible because smart guides are selected (View > Smart Guides).
As you drag, the objects are aligned to other objects on the artboard. Also notice
the gray box, or measurement label, that shows the object’s distance from its
original position. Measurement labels appear because smart guides are selected.

7 Deselect the airplanes by clicking the artboard where there are no objects, or by
choosing Select > Deselect.

8 Revert to the last saved version of the document by pressing the F12 key or
choosing File > Revert. In the Revert dialog box, click Revert.

Using the Direct Selection tool

The Direct Selection tool selects points or path segments within an object. Next you
will select anchor points and path segments using the Direct Selection tool.

1 With the same file open, switch to the Direct
Selection tool (I}) in the Tools panel. Without
clicking, move the pointer over the different points
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on the airplanes. When the Direct Selection tool
is over an anchor point of a deselected or selected
path or object, by default an anchor or path label,
such as the word anchor or path, appears.

Note: When you
select an item without
a fill, you must click on
the stroke (border).

Tip: Toselectall
objects, choose Select >
All. To select all objects
in a single artboard,
choose Select > All In
Active Artboard. To
learn more about
artboards, see
Chapter 3, “Creating
and Editing Shapes.”

Tip: If youdon't
want to use smart
guides at times, you
can deselect them by
choosing View >
Smart Guides.



2 Click the top point of the first airplane. Note that
only the point you selected is solid, indicating that
it is selected, while the other points in the airplane

Creating selections with a marquee

Some selections may be easier to make by creating a marquee around the objects
that you want to select. ’
are hollow and not selected.

P — I W—— 1 Inthe same file, switch to the Selection tool (). Instead of Shift-clicking to
e direction lines ex . ; " ) .
2 ll.lce i bbb e e diregction lines select the first two airplanes, position the pointer above the upper left airplane
anchor point. eend o : 3

and then click and drag downward and to the right to create a marquee that

are direction points. The angle and length of the

) overlaps just the tops of the airplanes.
direction lines determine the shape and size of the ps) P P

curved segments. Moving the direction points reshapes the curves.

Note: The gray 3 With the Direct Selection tool still selected, click
measurement label and drag the individual point down to edit the shape i
that appears as you B

i oin

of the object. Try clicking on other points. When

drag the anchor point s 0,471

hastha values dicard you click another point, the previous point

dy. Dx indicates the is deselected.

distance the pointer has

moved along the x axis 4 Revert to the last saved version by choosing File >

(horizontally), and dy Revert. In the Revert dialog box, click Revert. When dragging with the Selection tool, you only need to encompass a small part of an object to
indicates the distance include it in the selection.

the pointer has moved

along they . 2 Choose Select > Deselect or click where there are no objects.

axis (vertical). Selection and anchor

3 Now use the Direct Selection tool (lk) to perform the same action. Click outside
the first airplane and drag across to select the nose of each airplane in the
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Drag across the top points with the Direct Selection tool selects only those points.

point preferences

You can change selection preferences and how anchor points appear in the top row.

Tip: Using the Shift Preferences dialog box.

key, you can select
multiple points to move - = ‘ ......

them together. ]k

| Tolerance: |37 ] px | Dijrct Selectian by Path Only ©
®snaptafont 2 |px

~anchor Point and Handle Display

[ Highlight anc|
TIshow handles whi

mause over
wiltiple anchors are selecied

Choose Edit > Preferences > Selection & Anchor Display (Windows) or Only the top points become selected. Click one of the anchor points and drag
lllustrator > Preferences > Selection & Anchor Display (Mac OS). You can change the

size of anchor points (called anchors in the dialog box) or the display of the direc-
tion lines (called handles).

to see how the airplanes reposition together. Use this method when selecting a
single point. That way, you don't have to click exactly on the anchor point that

you want to edit.
You can also turn off the highlighting of anchor points as the pointer hovers
over them. As you move the pointer over anchor points, they are highlighted.
Highlighting anchor points makes it easier to determine which point you are about
to select. You learn more about anchor points and anchor point handles in
Lesson 5, “Drawing with the Pen and Pencil tools.”

4 Choose Select > Deselect.




Tip: Youcan
customize the Magic
Wand tool to select
objects based on stroke
weight, stroke color,
opacity, or blending
mode by double-
clicking the Magic
Wand tool in the Tools
panel. You can also
change the tolerances
used to identify
similar objects.

Creating selections with the Magic Wand tool

You can use the Magic Wand tool to select all objects in a document that have the
same or similar color or pattern fill attributes.

1 Select the Magic Wand tool (%) in the Tools panel. Click the apple and notice
that the fish is selected as well. No bounding box (a box surrounding the two
shapes) appears because the Magic Wand tool is still selected.

When selecting with the Magic Wand tool, objects with the same color fill are selected as well.

2 Click one of the baseball hats with the Magic Wand tool. Notice that both hats
are selected and that the apple and fish are deselected.

3 Holding down the Shift key, use the Magic Wand tool to click the apple. This
adds the apple and fish to the selection since they have the same fill color {red).
With the Magic Wand tool still selected, hold down Alt (Windows) or Option
(Mac OS) and click the apple again to deselect the red objects. Release the keys.

4 Choose Select > Deselect or click where there are no objects.

Grouping items

You can combine objects in a group so that the objects are treated as a single unit.
This way, you can move or transform a number of objects without affecting their
attributes or relative positions.

1 Select the Selection tool (k). Click outside the top right airplane and drag a

marquee that touches both airplanes, the fish, and apple to select all four objects.

2 Choose Object » Group, and then choose Select > Deselect.

3 With the Selection tool, click the apple. Because it is grouped with the other
three objects, all four are now selected. Notice that the word Group appears on
the left side of the Control panel.

4 Choose Select > Deselect.

Adding to a group

Groups can also be nested—they can be grouped within other objects or groups to
form larger groups.

With the Selection tool (R), click an airplane to select the grouped objects.
Shift-click the left hat in the third row to add it to the selection. Choose Object >
Group. The bounding box is expanded to include the hat.

Shift-click the right hat in the third row and then choose Object » Group.

You have created a nested group—a group within a group. Nesting is a common
technique used when designing artwork.

Choose Select > Deselect.

With the Selection tool, click one of the grouped objects. All objects in the group
become selected.

Click a blank area on the artboard to deselect the objects.

Hold down the Direct Selection tool {[}) in the Tools panel, and drag to the right
to access the Group Selection tool (Y ).

Click once on the left airplane to select the object. Click again to select the
object’s parent group. The Group Selection tool adds each group to the selection
in the order in which it was grouped.

The Group Selection tool adds the object’s parent group(s) to the current selection.

Choose Select > Deselect.

With the Selection tool, click any object to select the group of objects. Choose
Object » Ungroup to ungroup the objects. You must repeat this action for each
group. For this lesson, to completely ungroup all objects, you need to choose
Object > Ungroup three times.

Note: After step
1, notice that the
bounding box also goes
around the hat on the
right in the third row.
Look for anchor points
to indicate if the object
is actually selected.



Tip: Toenter
isolation mode, you
can also select a group
with the Selection tool
and click the Isolate
Selected Object
button () in the
Control panel.

Tip: To exit isolation
mode, you can alsc
click the gray arrow in
the upper left corner
of the Document
window until isolation
mode disappears. Or,
click the Exit isclation
mode button (&) in the
Control panel.

Working in isolation mode

Isolation mode isolates groups or sublayers so that you can easily select and edit
specific objects or parts of objects. When you use isolation mode, you don’t need

to worry about what layer an object is on, nor do you need to manually lock or hide
the objects you don't want affected by your edits. All objects outside of the isolated
group are locked so that they aren't affected by the edits you make. An isolated
object appears in full color, while the rest of the artwork appears dimmed, letting
you know which content you can edit.

1 With the Selection tool (&), click a blank area of the artboard to deselect, and
then drag a marquee across the fish and apple to select them. Choose Object >
Group. The word Group appears in the Control panel indicating that a group is
now selected.

2 With the Selection tool, double-click the apple to enter isolation mode.

At the top of the Document window, a

- LZstart_01.ai* @ B6% (CMYE/Preview) X E
gray arrow appears with the words Layer 1 A

and <Group>. This indicates that you have
isolated a group of objects that is on layer
1. You learn more about layers in Lesson 8, “Working with Layers.” Notice that
the rest of the content on the page appears dimmed (you can't select it).

3 Click the fish to select it. Drag it to the left.

When you enter isolation mode, groups are temporarily ungrouped. This enables
you to edit objects in the group without having to ungroup.
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Double-click outside of the objects to exit isolation mode.

Click to select the fish. Notice that it is once again grouped with the apple and
you can now select other objects on the page.

6 Choose Select > Deselect.

Selecting similar objects

You can also select objects based on fill color, stroke color, stroke weight, and more.
The stroke of an object is its outline, and the fill is a color applied to the interior
area. Next you will select several objects with the same fill color.

1 With the Selection tool (R), click to select the baseball hat on the left.

2 Click the arrow to the right of the Select Similar Objects button (%)) in the
Control panel to reveal a menu. Choose Fill Color to select all objects on the

artboard with the same fill color (orange). Notice that both hats are selected.
3 Choose Select > Deselect.

4 Choose File > Close, and don’t save the file.

Applying selection techniques |

In this lesson, you will use some of the techniques discussed previously in this chap-

ter, as well as other selection options.

1

i
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10 Click outside of the shapes to deselect the

11 Press Escape to exit isolation mode.

Choose File > Open, and open the L2start_02.ai file in the Lesson02 folder,
located in the Lessons folder on your hard disk. This document has two
artboards that you will navigate.

Press Shift+Tab to hide the panels. You can also hide the panels individually or
by groups using the Window menu.

Choose 2 from the Artboard Navigation menu in the lower left corner of the
Document window. Make sure that the current artboard is visible by choosing
View > Fit Artboard In Window. For information on navigating multiple
artboards, see Chapter 1, “Getting to Know the Work Area.” Artboard 2 shows

the final assembled artwork.

Choose 1 from the Artboard Navigation menu to return to the first artboard. Tip: To navigate
artboards, you can also
click the Previous or
Mext buttons, or click
the First or Last buttons
to the left and right

of the Artboard
Navigation menu.

Choose View > Zoom Out to see both artboards.

Holding down the spacebar to temporarily access the Hand tool (€, click and
drag the artboards to the left until you see both artboards completely.

Choose View > Smart Guides to deselect smart guides temporarily.

With the Selection tool (&), select the white daisy
flower shape in artboard 1. Notice that it is part of a
group of objects, and that the word Group appears in
the Control panel. To avoid grabbing a bounding box
handle and accidently resizing the shapes, click and
drag the yellow center of the flower group to slide it to
its new location as the head of the green flower stem

on the left.

Double-click the yellow center to enter isolation
mode. Click to select the light yellow shape and drag it
so that it's more centered on the other two shapes.

vellow center.
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2 The large words in this artwork

192 Double-click the Hand tool (£7) in the Tools panel to fit the artboard in
the window.

20 Select the Selection tool. The sunflower center consists of four small, light brown
ellipses. Click to select one of the ellipses. In the Control panel, click the Select
Similar Objects button (%)) to select all four of the ellipses. Choose

Object > Group. Drag the group into position in the center of the orange and
brown sunflower.

21 Using the Selection tool, hold down Alt (Windows)
or Option (Mac OS) to copy, or clone, the group of
ellipses. With the key held down, drag the flower
center group to the center of the white flower.
Position the cloned group as the white flower’s
center. Make sure to release the mouse button before
releasing Alt or Option.

Note: If you alsc hold down the Shift key when cloning, the
clened object is constrained and snaps to a straight 45°, 90°, or
180° angle.

Press Alt or Option and
drag to clone, or copy, the

22 Choose File » Save and then File > Close. center ellipse shapes.

Advanced selection techniques

When working on complex artwork, selections may become more difficult to
control. In this section, you'll combine some of the techniques you've already
learned with additional features that make selecting objects easier.

1 Open the file named T i
L2start_03.ai in the Lesson02 *  ARR
folder of Lessons folder.

malke it difficult to select items i
underneath. Using the Selection ,l’/)' - A (£
tool (W), select the word “Fries,” (/C g
and choose Object > Hide >

Selection or press Ctrl+3

(Windows) or Command+3 (Mac OS). The word is hidden so that vou can more
easily select other objects.

Note: The Select
Similar Objects button
remembers the last

menu item you chose
(fill color for this lesson),
When you click the
button, it selects objects
with the same fill color.



Note: Using the
Select menu is the same
as choosing a value
from the Select Similar
Objects (%) menu in
the Control panel.

Tip: Itis helpful
to name selections
according to use or
function. In step 8, if
you name the selection
3 pt stroke, for instance,
the name may be
misleading if you later
change the stroke
weight of the object.

3 Select any small red star and choose Select >
Same > Fill & Stroke. All the other red
stars are now selected. Click Fill color in
the Control panel and select white in the
Swatches panel that appears. The stars all
change to white.

4 Close the Swatches panel by pressing Escape.

5 Select one of the shapes within the french
fries and then choose Select » Same > Stroke Weight. The french fry shape has a
1.5 pt stroke, so all strokes that are 1.5 pt are now selected.

6 There is another artboard

Jofn Fies
it

to the right of the current

artboard. Choose

View > Zoom Qut to sec

both artboards. If necessary,
hold down the spacebar

to temporarily select the
Hand tool (§7) and drag the
artboards to the left until you
see both of them.

When you use the select similar commands, similar objects on all artboards are
selected by default.

7 Choose 3 pt from the Stroke Weight menu to increase the stroke weight.

8 With the previous selection still active, choose Select > Save Selection. Name the
selection french fries, and click OK. You can choose this selection at a
later time.

9 Choose Select > Deselect to deselect the objects. Choose Select > french fries
from the bottom of the Select menu to make the selection active. Change the
stroke weight to 2 pt in the Control panel.

10 Choose Object > Show All. The text Fries now appears and is selected. Keep the
file open for the next exercise and the Fries text still selected.

Locking selected objects

As you create more complex artwork, existing objects may get in the way and make
it difficult to select objects. Besides hiding objects, a common technique is to lock
selected artwork.

* Tolock an object: Select an object (or objects), then choose
Object > Lock > Selection, or Ctrl+2 (Windows) or Command+2 (Mac 0S). A
locked object cannot be moved or selected although it can still be seen. Unlock
all objects at the same time by choosing Object > Unlock All, or use Ctrl+Alt+2
(Windows) or Command+Option+2 (Mac OS).

—From lllustrator Help

Aligning objects

Multiple objects may need to be aligned or distributed relative to each other, the

artboard, or the crop area. In this section, you will explore the options for aligning

objects and aligning points.

1 In the L2start_03.ai file, Shift-click the text
French with the Selection tool (R) to select
the text French and the text Fries. Click the
Horizontal Align Left button () in the
Control panel, or if you don’t see the Align
options, click the word Align in the Control
panel to open the Align panel. Notice that Fries moves to align with the
word French.

2 Choose Edit > Undo Align to undo the alignment.

Aligning to a key object

A key object is an object that vou want other objects to align to. You specify a key
object by selecting all the objects you want to align, including the key object, and
then clicking the key object again. When selected, the key object has a thick blue
outline, and the Align To Key Object icon appears in the Control panel and the
Align panel.

3 With the French and Fries text objects still
selected, click Fries with the Selection tool. The
thick blue outline indicates that it is the key
object that other objects align to.

Note: The Align
options may not appear
in the Control panel,
but are indicated by the
word Align. lllustrator
fits as many options
as it can in the Control
panel, depending on
your screen resolution.

Tip: Inthe Align
panel, you can also
choose Align To Key
Object from the Align
To option. The object
that is in front becomes
the key object.



Note: The Distribute
Spacing options in the
Align panel distribute
the space between the
objects, not the left,
center, or right edges of
the objects.

Tip: You can also
assign a specific spacing
between objects using
the Distribute
Spacing options.

4 In the Align options in the Control panel or
the Align panel, ¢lick the Horizontal Align Left
button (2,). Notice that French moves to align -
with Fries.

5 Choose Select > Deselect.

Aligning points
Next you'll align two points to each other using the Align panel.

1 With the Selection tool, Shift-click the words French and Fries and choose
Object > Hide > Selection.

2 With the Direct Selection tool (y), click the
bottom left point of the red french fries box,
and then Shift-click to select the top left point.

You are selecting the points in a certain order
because the last selected anchor point is the key
anchor. Other points align to the last selected

anchor point.

) Shift-click to select two
3 Click the Horizontal Align Left button () in anchor points.

the Control panel.

Note: If you don't see the Align options, click the word Align in the Control panel to reveal the
Align panel.

4 Choose Object > Show All to reveal the text again.

Distributing objects

Distributing objects enables you to select multiple objects and distribute the spacing
between those objects equally. The distribute options are also found in the Align
panel. For example, if you have three stars and then click Horizontal Distribute
Center, the leftmost and rightmost objects stars do not move and the middle star is
repositioned so that its center point is halfway between the other two stars.

1 Click the Next button () in the lower left corner of the Document window to go
to artboard 2.

2 Choose View > Fit Artboard In Window if the artboard isn’t showing in the
Document window.,

3 With the Selection tool (R), drag across the
four stars above the John Fries text to select
them all.

“John Friek

4 Click the Horizontal Distribute Center johnf@friesfrench.com

button () in the Control panel. This moves

the center two stars so that the spacing
between the center of each star is equal.
Choose Select > Deselect.

5 With the Selection tool, click the rightmost

===
star. Keep the mouse button held down, CrOrTEE Ty
and Shift-drag to the right to keep the star John Frie®

vertically aligned with the other stars. Drag johnf@friesfrench.com

to the right until the right edge of the star is

even with the letter s in John Fries.

Shift-drag the rightmost star to

6 Select all four stars again, and click the
the right.

Horizontal Distribute Center button again.
Notice that with the rightmost star repositioned, the center two stars move to
distribute the spacing between all the star center points. Choose

Select > Deselect.

Aligning to the artboard

You can also align content to the artboard rather than other objects. With this
method, each individual object is aligned separately to the artboard. Next you'll
align the words French and Fries to the center of the artboard.

1 Click the Previous button (d) in the lower left corner of the Document window to
return to the first arthoard.

2 With the Selection tool (&), Shift-click to select the words French and Fries.

3 Choose Object > Group to group the objects together.

4 Click the Align To Selection button () and T L

appears (if it isn’t already selected). Setting this
option ensures that all future alignments are
aligned to the artboard. Click the Horizontal
Align Center (%) button to align the objects to

choose Align To Artboard from the menu that
¥ ,—‘ 1 P o= ———
= A <‘
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the horizontal center of the artboard.

5 Choose File > Close without saving, unless you After aligning to the artboard
want to complete the Exploring on your
own section.

Note: When you
want to align all
content for a poster,
for example, to the
center of the artboard,
grouping the objects
is an important step.
Grouping moves the
objects together as
one object, relative
to the artboard. If this
isn't done, centering
everything horizontally
moves all the objects to
the center independent
of each other.




About align options

The Align panel has a lot of features that are very useful in Illustrator. Not only can
you align objects, but you can also distribute objects as well. Select the cbjects to
align or distribute, then, in the Align panel, do any of the following:

= Toalign or distribute relative to the bounding box of all selected objects, click
the button for the type of alignment or distribution you want.

= Toalign or distribute relative to one of the selected objects (a key object), click
that object again (you don't need to hold down Shift as you click this time).
Then click the button for the type of alignment or distribution you want,

Note: To stop aligning and distributing relative to an object, choose Cancel Key
Object from the Align panel menu.

* To align relative to the active artboard, click the Align To Artboard button ([ or
click the Align menu (arrow to the right of the Align To Artboard button)
and choose Align To Artboard. Then click the button for the type of alignment
you want.

—From lllustrator Help

Exploring on your own
1 Experiment by cloning a star from L2start_03.ai. Clone it several times using the
Alt or Option key.

2 Apply different colors and strokes to the shapes and reselect them using the
Select Same menu item.

3 Select three stars from L2start 03.ai and try some of the distribute objects
options in the Align panel.

4 Select three stars and click one of them to set it as the key object. Align the other
selected stars to the key object using the align options in the Align panel. Keep
the stars selected.

5 Choose Object > Group.

6 With the Selection tool, double-click one of the stars in the group to enter
isolation mode.

7 Resize several of the stars by clicking and dragging each star’s bounding box.
8 Press Escape to exit isolation mode.

9 Close the file without saving.

Review questions
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How can you select an object that has no fill?
Name two ways you can select one item in a group without choosing Object > Ungroup.
How do you edit the shape of an object?

What should be done after spending a lot of time creating a selection that is going to be
used repeatedly?

If something is blocking your view of a selection, what can you do?

To align abjects to the artboard, what must be selected in the Align panel or Control
panel before you choose an alignment option?

Review answers

You can select items that have no fill by clicking on the stroke or dragging a marquee

across the object.

Using the Group Selection tool, you can click once for an individual item within a
group. Continue to click to add the next grouped items to the selection. Read Lesson 8,
“Working with Layers,” to see how you can use layers to make complex selections. You
can also double-click the group to enter isolation mode, edit the shapes as needed, and
then exit isolation mode by pressing Escape or double-clicking outside of the group.

Using the Direct Selection tool, you can select one or more individual anchor points
and make changes to the shape of an object.

For any selection that you need to use again, choose Select > Save Selection. Name the
selection and reselect it at any time from the Select menu.

If something is blocking your access to a selection, you can choose
Object > Hide > Selection. The object is not deleted, just hidden in the same position
until you choose Object > Show All

To align objects to artboard, the Align To Artboard option must be selected first.




